ANNOUNCE: gob2 2.0.4 the "Bits of confusion" release

From: George <>
Date: Sat, 14 Dec 2002 00:31:31 -0800


Two more minor fixes to gob, this time to the gtkdoc handling. So a time
for a new release. I actually built rh8 RPMS this time (sorry only rh8
since that's what I have:). Also there was a little bit of confusion I
think and Jody made some sort of a release somewhere that had a weird version
number or some such (2.1.whatever). Don't worry, that release was identical
to 2.0.3, so just ignore it. I can't find a tarball of that anyway. 2.0.4
is the newest, stable and there is no development release.

So what is this gob thing? Well besides being the cure for cancer, it also
generates GObjects (or GTK+ objects). GOB2 is a replacement for the version
1 GOB, that was for GTK+ 1.x mostly. GOB2 can handle pretty much most of
the GObject features. At least most of the ones that anyone will ever use.
It only requires GLib 2.0 and can generate arbitrary GObjects. You can have
both versions installed at the same time if you wish, so that you don't have
to port all your gob files to gob2 for now, but you really should as gob2 is
nicer and all that kind of stuff.

Here are the news in 2.0.4 (gob2):

        * Fix two gtkdoc bugs
        * Use G_UNLIKELY/G_LIKELY a bit if available

Have fun,


George <>
   You have the right to free speech,
   as long as you're not dumb enough to actually try it!
                                         -- The Clash
Received on Sat Dec 14 2002 - 03:31:51 CST

This archive was generated by hypermail 2.2.0 : Sun Apr 17 2011 - 21:05:02 CDT